Excel: VERT.ZOEKEN leeg als leeg weergeven en 0 als 0 weergeven [Opgelost]

Rapporteren
-
Gepubliceerde berichten
1766
Inschrijfdatum
vrijdag 3 april 2015
Status
Beheerder
Laatste deelname
9 oktober 2020
-
Als ik verticaal zoeken toepas en in de formule aangeef dat een leeg vakje ook leeg moet worden weergegeven, dan wordt een 0 ook als leeg weergegeven.
Hoe kan ik de 0 als waarde wel laten weergeven?

De formule die ik gebruik is:
=ALS(VERT.ZOEKEN(A7;Totaal!$B$3:$CY$146;12;ONWAAR);VERT.ZOEKEN(A7;Totaal!$B$3:$CY$146;12;ONWAAR);"")
Dus:
1. zoek op tabblad 'Totaal' in gebied B3-CY146 naar de waarde die op het huidige tabblad in cel A7 staat (bijvoorbeeld 'Piet')
2. geef de waarde die in de 12e kolom rechts van 'Piet' staat
3. als de gevonden cel leeg is, laat de doelcel dan leeg

Lastig is dat als in de gevonden cel een 0 staat, dat dan de doelcel ook leeg wordt gelaten en dat is niet de bedoeling

1 antwoord

Gepubliceerde berichten
1766
Inschrijfdatum
vrijdag 3 april 2015
Status
Beheerder
Laatste deelname
9 oktober 2020
4.547
Beste Theo,

Alles gerelateerd aan nulwaarden in Excel kan al snel vrij ingewikkeld zijn. Ik denk dat je het beste het volgende artikel op de officiële Microsoft Office-website kunt raadplegen. Daar wordt aangegeven wat je moet doen om een 0 als waarde te laten tellen, in plaats van als lege cel te beschouwen.

Hopelijk gaat het je hiermee lukken.

Groetjes,

Bob
CCM